Google
www GarfNet
moon phase
Solar X-rays:
Geomag. Field:
Status
Status
Home Articles Technology How to install PHPRunner 4.0 on Ubuntu Linux  

Login Form



Related Items



How to install PHPRunner 4.0 on Ubuntu Linux PDF Print E-mail
Written by Garfield Lucas   

ImagePHPRunner is arguably the best PHP scripting tool currently available. Trouble is that at time of writing, there is only a version for M$ Windoze. This explains how I managed to persuade it work under Linux using Codeweavers CrossoverOffice 6.1.0 - a comercial implementation of WINE.

First, I  downloaded PHPRunner 4.0 "Build 264" - the special Linux friendly version kindly prepared by its developer Sergey Kornilov - the one he created minus Microsoft ADSI dependency. 

FYI, I am using on Kubuntu 7.04 (Feisty). IMHO the Ubuntu family of Debian-based Linuxes are the easiest to install, configure and use for folks coming from a Windows background, though no doubt many would disagree! smile.gif

This is how I did it...

Create bottle called something like phprunner40-linux, make sure you create it as a Win98 bottle. This enables you to install all the dependencies. It seems to like it if you install all dependencies FIRST and obviously make sure they are installed in the phprunner40-linux bottle!

Then select and install in this order...

  1. DCOM98, this forces the installing of Windows OLE components and Windows OLE components (part 2) - and makes it accessible to phprunner.
  2. Internet Explorer 6 SP1 - choose advanced install which will allow you do install ALL the IE components you need (and I suspect some you probably don't!)
  3. Then click "install unsupported software" and install phprunner40-linux. And make sure you actually install it in the phprunner40-linux bottle you just prepared!

During the install it is a good idea to create a desktop icon. Later, you might need to copy and paste its properties into the menu item the installer creates.

Now here is the important part...

You must now convince "PHPRunner.exe" that it is a Windows XP application. Then you must also do a "libarary override" for the PHPRunner.exe file. This is how to do it...

  • In the winecfg tool (Crossover Configuration | "Configure" button | "Control Panel" tab | "Winecfg" item), select "PHPRunner.exe" if it is in the list.
  • If it isn't in the list then you will need to click the "Add Application" button, then browse and find the "PHPRunner.exe" file.
  • Then, making sure the "PHPRunner.exe" file is selected, use the "Windows" pick list near the bottom of the dialog, to select "WinXP" and click "Apply" button.
  • Then, making sure the "PHPRunner.exe" file is still selected, click the "Libraries" tab.
  • From the "new override for library" picklist select "activeds (native,builtin)" and click "Add" button.
  • Click "Apply" button. Then close the winecfg dialog.
  • Click "OK" button to dismiss the "Configuring Bottle" dialog.
  • Click "Exit" button to dismiss the original Crossover config dialog.

Now launch PHPRunner from the desktop icon - et voila! I tried this installation procedure several times with 100% success each time. Granted, it's a bit of a performance but it works great! Also gives you a pretty good implementation of Internet Explorer on Linux too!

 


Last Updated on Monday, 07 January 2008 02:11
 

Search

Clock

Who's Online

We have 17 guests online

© 2014 GarfNet
Joomla! is Free Software released under the GNU General Public License.